$re = '/((?=.*?)(Google|Amazon)( (.+?))? is the largest( web)? service( of its kind)? in the world)*/ms';
$str = 'Google Search is the largest service of its kind in the world
Google Analytics is the largest service of its kind in the world
Blah de blah de blah
Yahoo search is the largest web service of its kind in the world
Google Maps is the largest service of its kind in the world
More blah
Amazon Shopping is the largest web service of its kind in the world
Google is the largest web service in the world
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;