import Foundation
let pattern = #"((?=.*?)(Google|Amazon)( (.+?))? is the largest( web)? service( of its kind)? in the world)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Google Search is the largest service of its kind in the world
Google Analytics is the largest service of its kind in the world
Blah de blah de blah
Yahoo search is the largest web service of its kind in the world
Google Maps is the largest service of its kind in the world
More blah
Amazon Shopping is the largest web service of its kind in the world
Google is the largest web service in the world
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)