$re = '/(?<=by )(\w+) (\w+)/i';
$str = 'Medical Student H&P by FnameMS LnameMS at 04/11/16 1257';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);