re = /(?<=by )(\w+) (\w+)/i
str = 'Medical Student H&P by FnameMS LnameMS at 04/11/16 1257'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end