$re = '/"lat":"\s*([^"]*?\s*"),"lng":"\s*([^"]*?\s*)"\K/';
$str = '\'"id":75549,"name":"Name","lat":"45.491834","lng":" -73.606953","address"\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);