const regex = /^[_A-Za-z0-9-\+]+(\.[_A-Za-z0-9-]+)*[^~@#\^\$&\*\(\)\-_\+=\[\]\{\}\|\\,\.\?\s]@[^~@#\^\$&\*\(\)\-_\+=\[\]\{\}\|\\,\.\?\s]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*[^~@#\\^\\$&\\*\\(\\)\\-_\\+=\\[\\]\\{\\}\\|\\\\,\\.\\?\\s]@[^~@#\\^\\$&\\*\\(\\)\\-_\\+=\\[\\]\\{\\}\\|\\\\,\\.\\?\\s]+(\\.[A-Za-z0-9]+)*(\\.[A-Za-z]{2,})$', '')
const str = `schlebach+62@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}