import re
regex = re.compile(r"^[_A-Za-z0-9-\+]+(\.[_A-Za-z0-9-]+)*[^~@#\^\$&\*\(\)\-_\+=\[\]\{\}\|\\,\.\?\s]@[^~@#\^\$&\*\(\)\-_\+=\[\]\{\}\|\\,\.\?\s]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})$")
test_str = "schlebach+62@gmail.com"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")