using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[a-zA-Z]+(?:(?!&[lg]t;).)*>";
string input = @"<a href=""http:foo""<a href=""http:foo"">";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}