re = /<[a-zA-Z]+(?:(?!&[lg]t;).)*>/
str = '<a href="http:foo"<a href="http:foo">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end