#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\w+\.(pdf|m4v)$"
Local $sString = "abc.pdf" & @CRLF & _
"" & @CRLF & _
"abc.m4v" & @CRLF & _
"" & @CRLF & _
"abc.abc" & @CRLF & _
"" & @CRLF & _
"acb.dfs" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")