$re = '/^\w+\.(pdf|m4v)$/im';
$str = 'abc.pdf
abc.m4v
abc.abc
acb.dfs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);