using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"::(?!.*?\]\]$)";
string substitution = @"/";
string input = @"SID:Common::Location ABE::Sub Location ABE
[[Maps to SID::toto tata]]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}