$re = '/::(?!.*?\]\]$)/';
$str = 'SID:Common::Location ABE::Sub Location ABE
[[Maps to SID::toto tata]]';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;