use strict;
my $str = 'leaflet-0.7.2.js
/leaflet-0.7.2.js
http://leafletjs.com/dist/leaflet.js
https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js
http://example.com/path/to/leaflet-0.7.2.js
http://example.com/path/to/mapbox-v1.6.2.js
http://leafletjs.com/dist/leaflet.js?v=123456&hide=true#section
';
my $regex = qr/(?'location'.+)(?:\/(?'resource'[\w\-\._]+\.js))(?:\?(?'params'.+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}