$re = '/(?\'location\'.+)(?:\/(?\'resource\'[\w\-\._]+\.js))(?:\?(?\'params\'.+))?/m';
$str = 'leaflet-0.7.2.js
/leaflet-0.7.2.js
http://leafletjs.com/dist/leaflet.js
https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js
http://example.com/path/to/leaflet-0.7.2.js
http://example.com/path/to/mapbox-v1.6.2.js
http://leafletjs.com/dist/leaflet.js?v=123456&hide=true#section
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);