package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{1,3}[\.]){3}([0-9]{1,3})([\/]3[0-2]|3[0-3][0-3][0-3])?`)
var str = `
192.168.1.1/333
192.168.1.1/32
192.168.1.1/a
192.168.1.1
192.168.1.1/33
192.168.1.1/24
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}