use strict;
my $str = '
192.168.1.1/333
192.168.1.1/32
192.168.1.1/a
192.168.1.1
192.168.1.1/33
192.168.1.1/24
';
my $regex = qr/([0-9]{1,3}[\.]){3}([0-9]{1,3})([\/]3[0-2]|3[0-3][0-3][0-3])?/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}