package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([[:alpha:]_]\w*[[:alnum:]])?(\/([[:alpha:]_]\w*[[:alnum:]]))*$`)
var str = `Soren/asDAS/AFASFsf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}