re = /^([[:alpha:]_]\w*[[:alnum:]])?(\/([[:alpha:]_]\w*[[:alnum:]]))*$/
str = 'Soren/asDAS/AFASFsf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end