package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.cookie\([^,()]+,[^()]+\)`)
var str = `$.cookie('sessionId')
$.cookie('importantAnnouncements.dismissed', true, {expires: 365});`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}