$re = '/\.cookie\([^,()]+,[^()]+\)/m';
$str = '$.cookie(\'sessionId\')
$.cookie(\'importantAnnouncements.dismissed\', true, {expires: 365});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);