package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"renderer":(.*?)(?:,)`)
var str = `{"columns":[{"text":"A","value":80},{"text":"B","renderer":"gbpFormat","value":80},{"text":"C","value":80}]}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}