$re = '/"renderer":(.*?)(?:,)/';
$str = '{"columns":[{"text":"A","value":80},{"text":"B","renderer":"gbpFormat","value":80},{"text":"C","value":80}]}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);