using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B(\*+)(\s*\b)(\b\*+\b|[^*])*(\s*)(\*+)\B";
string input = @"*** Strong italic text ***, and even just *strong text *, when rendered in * Markdown*, doesn't like *spaces * around the boundaries of the stars.
* You can see it also within the li**n**es here. *
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}