$re = '/\B(\*+)(\s*\b)(\b\*+\b|[^*])*(\s*)(\*+)\B/m';
$str = '*** Strong italic text ***, and even just *strong text *, when rendered in * Markdown*, doesn\'t like *spaces * around the boundaries of the stars.
* You can see it also within the li**n**es here. *
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);