$re = '~^.+?(?= / |$)~m';
$str = 'Atomic grouping / possessive qualifiers / conditional and recursive patterns
abc and/or def xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);