re = /^.+?(?= \/ |$)/m
str = 'Atomic grouping / possessive qualifiers / conditional and recursive patterns
abc and/or def xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end