import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(no)|\n"
+ "(yes)(?!.*yes)|\n"
+ "((?!(?=(?<a>[\\s\\S]*))(?<b>yes.*(?=\\k<a>\\z)|(?<=(?=x^|(?&b))[\\s\\S])))yes)";
final String string = "no/yes\n"
+ "no/yes/yes/no\n"
+ "/yes/yes/no/yes\n"
+ "no/word/no/yes/yes/yes/no\n"
+ "yes/no\n"
+ "yes/no/yes/word/yes\n"
+ "/word/yes/no/no/no/yes/yes\n"
+ "yes/no/yes/yes\n\n";
final String subst = "${1:+-:+}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}