$re = '/(^(.*?)_|Date(.*?)\))/';
$str = 'Subject(учебники Разумник)_Разумник_наличие_Date(Mon, 16 Jan 2017 13_37_50 +0300).zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);