// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^(.*?)_|Date(.*?)\))").unwrap();
let string = "Subject(учебники Разумник)_Разумник_наличие_Date(Mon, 16 Jan 2017 13_37_50 +0300).zip";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}