const regex = /(\b(?:' . wp_posts . '\.)?post_author\s*=\s*(' . 1 . '))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?:\' . wp_posts . \'\\.)?post_author\\s*=\\s*(\' . 1 . \'))', 'gm')
const str = `AND (wp_posts.post_author = 1) AND wp_posts.post_type = 'post' AND (wp_posts.post_status = 'publish' OR wp_posts.post_author = 12 AND wp_posts.post_status = 'private')
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}