$re = '/(\b(?:\' . wp_posts . \'\.)?post_author\s*=\s*(\' . 1 . \'))/m';
$str = 'AND (wp_posts.post_author = 1) AND wp_posts.post_type = \'post\' AND (wp_posts.post_status = \'publish\' OR wp_posts.post_author = 12 AND wp_posts.post_status = \'private\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);