package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+44)(\d{4})`)
var str = `+442070320811
2070 320811`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}