use strict;
my $str = '{u\'bearing\': 0, u\'altitude\': 0, u\'time\': 1423728072412L, u\'longitude\': -118.38120859999991, u\'provider\': u\'network\', u\'latitude\': 34.052508400000001, u\'speed\': 0, u\'accuracy\': 20}{u\'bearing\': 0, u\'altitude\': 0, u\'time\': 1423728072412L, u\'longitude\': -118.38120859999992, u\'provider\': u\'network\', u\'latitude\': 34.052508400000001, u\'speed\': 0, u\'accuracy\': 20}';
my $regex = qr/(?<=longitude':)\s*([^,}]*)|(?<=latitude':)\s*([^,}]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}