$re = '/(?<=longitude\':)\s*([^,}]*)|(?<=latitude\':)\s*([^,}]*)/';
$str = '{u\'bearing\': 0, u\'altitude\': 0, u\'time\': 1423728072412L, u\'longitude\': -118.38120859999991, u\'provider\': u\'network\', u\'latitude\': 34.052508400000001, u\'speed\': 0, u\'accuracy\': 20}{u\'bearing\': 0, u\'altitude\': 0, u\'time\': 1423728072412L, u\'longitude\': -118.38120859999992, u\'provider\': u\'network\', u\'latitude\': 34.052508400000001, u\'speed\': 0, u\'accuracy\': 20}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);