const regex = /(?=^[A-Z])(?=.{1,4}\d)(?=.*[A-Za-z])[A-Za-z\d]{8,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^[A-Z])(?=.{1,4}\\d)(?=.*[A-Za-z])[A-Za-z\\d]{8,}', '')
const str = `Ab2Dfsss`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}