$re = '/(?=^[A-Z])(?=.{1,4}\d)(?=.*[A-Za-z])[A-Za-z\d]{8,}/';
$str = 'Ab2Dfsss';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);