#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:,\d+)?(?:-\d+(?:,\d+)?)?$"
Local $sString = "8,4-10" & @CRLF & _
"8,4-10,5" & @CRLF & _
"8,4-10,5-3" & @CRLF & _
"8,4-" & @CRLF & _
"25" & @CRLF & _
"25,5" & @CRLF & _
"24.1" & @CRLF & _
"1a" & @CRLF & _
"abc" & @CRLF & _
",,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")