$re = '/^\d+(?:,\d+)?(?:-\d+(?:,\d+)?)?$/m';
$str = '8,4-10
8,4-10,5
8,4-10,5-3
8,4-
25
25,5
24.1
1a
abc
,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);