using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0?[0-9]|1[0-9]|2[0-3]):[0-9]+:(0?[0-9]|[1-5][0-9])";
string input = @"02:01";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}