package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0?[0-9]|1[0-9]|2[0-3]):[0-9]+:(0?[0-9]|[1-5][0-9])`)
var str = `02:01`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}