using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""\s*(?=(SELECT|INSERT|UPDATE|DELETE|CREATE|REPLACE|ALTER)\b)";
string input = @"""
SELECT table.field";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}