re = /"\s*(?=(SELECT|INSERT|UPDATE|DELETE|CREATE|REPLACE|ALTER)\b)/
str = '"
SELECT table.field'
# Print the match result
str.match(re) do |match|
puts match.to_s
end