re = /^NUMBER = (\d+)/m
str = 'NUMBER = 6367283940 | FOOD = PASTA | NAME = JOHN WALKER
NUMBER = 6367283940 | FOOD = PASTA | NAME = JOHN WALKER
NUMBER = 6367283940 | FOOD = PASTA | NAME = JOHN WALKER
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end