// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^NUMBER = (\d+)").unwrap();
let string = "NUMBER = 6367283940 | FOOD = PASTA | NAME = JOHN WALKER
NUMBER = 6367283940 | FOOD = PASTA | NAME = JOHN WALKER
NUMBER = 6367283940 | FOOD = PASTA | NAME = JOHN WALKER
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}