# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(((((#)|())(([ \t\n]+|()))([a-zA-Z0-9]+)([ \t\n]+))|())((([ \t\n]+|()))((move|mult)|([a-z]+)))((([ \t\n]+|()))(:))((([ \t\n]+|()))([a-zA-Z0-9,&\* \t\"\n\[\]]+))(;))|((([ \t\n]+|()))((save|end)|([a-z]+))(([ \t\n]+|()))(;))"
test_str = ("\n"
"{\n"
" stream: gogo;\n"
" move: some, reg1;\n"
" #jix mult: &num, reg2;\n"
" push: reg2;\n"
" sus : 0x20;\n"
" add : him, her;\n"
" #goto \n"
" jump: loop;\n"
" dec : him, *reg2;\n"
" #get\n"
" add : onu, buna;\n"
" jump: goto;\n"
" #mydear move: \"moses\", rgb[8]; \n"
" save ;\n"
" end ;\n"
"}\n\n\n"
"{\n"
" move: mos, reg1;\n"
" mult: &num, reg2;\n"
" push: reg2;\n"
" int : 0x20;\n"
" #lab\n"
" add : him, her;\n"
" jump: loop;\n"
" #mos\n"
" dec: him, *reg2;\n"
" #inst\n"
" add: onu, buna;\n"
" jump: lab;\n"
" save;\n"
" end;\n\n"
"}\n\n\n\n"
"{\n"
" inc: moses, to;\n"
" #io\n"
" push: him;\n"
" #kim\n"
" jump: frame;\n"
"}\n\n\n"
" okbro () {\n"
" dec: him, beat;\n"
" #his\n"
" push: him;\n"
" jump: main;\n"
" ret; }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.