const regex = /^(?:(?:http|https):\/\/)?(?:www.)?facebook.com\/(?:(?:\w)*#!\/)?(?:pages\/)?(?:[?\w\-]*\/)?(?:profile.php\?id=(?=\d.*))?([\w\-\.]*)?(?:\?fref=ufi)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:http|https):\\\/\\\/)?(?:www.)?facebook.com\\\/(?:(?:\\w)*#!\\\/)?(?:pages\\\/)?(?:[?\\w\\-]*\\\/)?(?:profile.php\\?id=(?=\\d.*))?([\\w\\-\\.]*)?(?:\\?fref=ufi)?$', '')
const str = `https://www.facebook.com/user.moreusername?fref=ufi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}