re = /^(?:(?:http|https):\/\/)?(?:www.)?facebook.com\/(?:(?:\w)*#!\/)?(?:pages\/)?(?:[?\w\-]*\/)?(?:profile.php\?id=(?=\d.*))?([\w\-\.]*)?(?:\?fref=ufi)?$/
str = 'https://www.facebook.com/user.moreusername?fref=ufi'
# Print the match result
str.match(re) do |match|
puts match.to_s
end