import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\D*(?:^|,)\\d(?:,|$)\\D*$)[\\d-](?:,[\\d-])+$";
final String string = "-,-,-,9,-\n"
+ "9,-,-\n"
+ "9,6,-,-\n"
+ "-,8,6,-\n"
+ "-,8\n"
+ "8,-\n"
+ "-,-,+,-\n"
+ "-,0,-,0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}