re = /^(?=\D*(?:^|,)\d(?:,|$)\D*$)[\d-](?:,[\d-])+$/m
str = '-,-,-,9,-
9,-,-
9,6,-,-
-,8,6,-
-,8
8,-
-,-,+,-
-,0,-,0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end